Of Code and Me

Somewhere to write down all the stuff I'm going to forget and then need

Motorola Xoom connects to wi-fi but not the internet – How to fix it May 7, 2011

Filed under: Android,Error,Xoom — Rupert Bates @ 9:01 am

I’ve recently got a Motorola Xoom tablet and when I first tried to connect to the internet at home was surprised and annoyed to find that although it would connect to my wifi no problem, it could not get an internet connection.

It seems that the problem lies in the DHCP interaction between the Xoom and my wireless router which results in the Xoom not picking up gateway information from the router. The solution was to configure a static IP address for the Xoom.

To do this do the following:

  • Go into Settings, then ‘Wireless & networks’ then ‘Wi-Fi settings’
  • Find your wi-fi network in the list and press and hold then select ‘Modify network’ from the pop up
  • Scroll down to the ‘IP settings’ drop down and switch it from DHCP to Static
  • In the ‘IP address’ box enter the same IP address which is shown higher up the same form
  • In the ‘Gateway’ box you will need to put the IP address of your router, to find this out I opened a command prompt window on a PC on the same network and typed ipconfig┬áthis will give you a Default gateway address which is what you need
  • In the the ‘Network prefix length’ box put 24 (this assumes the subnet mask from ipconfig is 255.255.255.0)
  • Finally in the ‘DNS 1’ box put the same IP you put in the Gateway box
Now click Save, disconnect and reconnect from the network and when you are reconnected you should have internet access.
Note: There has been some discussion around the save button being greyed out, resulting in the following:
“the save option is usually greyed out until you have entered your password at the top, network prefix, and dns 1. make sure you have entered these things or else it wont let you save. also make sure you have entered them and they are not just grey. “
Advertisements